Delivery of receipts currently delayed
Incident Report for Flux
Resolved
This incident has been resolved.
Posted Nov 14, 2020 - 19:45 UTC
Investigating
Delivery of receipts is currently delayed for all users. We're looking into this and will share an update as soon as we know more.
Posted Nov 13, 2020 - 19:14 UTC
This incident affected: 🏦 Banks (💜 Starling Bank, 🧡 Monzo, 💙 Barclays).