Barclays account creation is delayed
Incident Report for Flux
Resolved
This incident has been resolved.
Posted Jan 23, 2021 - 18:51 UTC
Investigating
We are currently experiencing a delay receiving account information from Barclays. Accounts created after 3pm today may not be fully registered.

We're looking into this and will share more as soon as we can.

Thank you for your patience while we look into this for you.
Posted Jan 22, 2021 - 17:52 UTC
This incident affected: 🏦 Banks (💙 Barclays).