Delayed delivery for some Just Eat x Monzo receipts
Incident Report for Flux
Resolved
Everything is working as expected and there have been no more missed receipts.
Posted Sep 06, 2021 - 09:24 UTC
Monitoring
All existing receipts have been re-processed. We are monitoring the situation to ensure there are not more receipts.
Posted Sep 03, 2021 - 16:41 UTC
Identified
We identified around 5,000 individual receipts from 1 September - 3 September that haven't yet been delivered. We've identified the problem and are manually re-processing the receipts now.

All affected customers should receive their receipts within the next 24 hours.

Thanks for your patience while we get this sorted 🙏🏼
Posted Sep 03, 2021 - 14:31 UTC
This incident affected: 🏪 Retailers (🛵 Just Eat).