We're not currently delivering receipts or offers for Just Eat transactions
Incident Report for Flux
Resolved
We're now delivering receipts again for Just Eat, please get in touch if you're missing your receipt or cash back.
Posted Oct 03, 2021 - 12:14 UTC
Investigating
We are currently investigating this issue.
Posted Oct 03, 2021 - 09:27 UTC
This incident affected: 🏪 Retailers (🛵 Just Eat).